All systems operational

OP Mainnet Bedrock Upgrade

Completed
Scheduled for June 06, 2023 at 4:00 PM – 10:48 PM

Affected

Mainnet
Bridge UI
Deposits
Withdrawals
Transaction Sequencing
Public API
Updates
  • Completed
    June 06, 2023 at 10:48 PM
    Completed
    June 06, 2023 at 10:48 PM

    Much of our our core OP Mainnet infra is back online! Continue to track https://oplabs.notion.site/External-OP-Mainnet-Bedrock-Upgrade-Infra-Status-Tracker-07d7c9c0916243b8b743b74af77d37f9?pvs=4 for updates on other key infrastructure in the OP Mainnet ecosystem.

    The Bridge UI has been unpaused. Deposits and Withdrawals can now be executed on OP Mainnet from: https://app.optimism.io/bridge/

  • Update
    June 06, 2023 at 9:52 PM
    In progress
    June 06, 2023 at 9:52 PM

    The public endpoint is back live: https://mainnet.optimism.io/

    This should unblock most wallets to begin working again.

  • Update
    June 06, 2023 at 7:38 PM
    In progress
    June 06, 2023 at 7:38 PM

    For Archival node operators: While we recommend using the legacy-geth archival datadir we upload once it's ready, given the size of the archival data disk and the time it'll take for it to become available (up to 24 hours), we recommend preserving your legacy archival nodes and routing archival traffic to them if possible. To check if your legacy archival node is able to serve traffic, please do the following:
    Verify that the head block number is 105235062
    Verify that the head block hash is 0x21a168dfa5e727926063a28ba16fd5ee84c814e847c81a699c7a0ea551e4ca50
    If both of these criteria are true, then your legacy archival node is on the same block as the archival datadir and can be used to serve user traffic.

    You can set --rollup.historicalrpc <l2geth-rpc> on op-geth and it will forward requests for historical data it can't handle to l2geth.

  • Update
    June 06, 2023 at 7:10 PM
    In progress
    June 06, 2023 at 7:10 PM

    For node operators:
    We have received reports that the full node Bedrock datadir is taking a long time to download. Since it is available on GCS, you can use parallel downloader tools like aria2 to make it faster. This method has seen download speeds in excess of 100MB/s. Some recommendations:

    • Run the download on a high-network box in the cloud.
    • Use aria2 or the gcloud storage cp command to download the file in parallel.
  • Update
    June 06, 2023 at 6:50 PM
    In progress
    June 06, 2023 at 6:50 PM

    The Bedrock sequencer has started up.

    Images, and data directories for node operators can be found here. Key external OP Mainnet infrastructure is starting to come back online. View the OP Mainnet Infra Tracker to follow along.

  • Update
    June 06, 2023 at 6:26 PM
    In progress
    June 06, 2023 at 6:26 PM

    L1 smart contract upgrades have been successfully implemented. The portal has been unpaused, and deposits/withdrawals have been re-enabled.

  • Update
    June 06, 2023 at 6:20 PM
    In progress
    June 06, 2023 at 6:20 PM

    The migrated (Bedrock) datadir required to spin up op-geth has been successfully hosted and is now ready for distribution.

    Full Node Operators are now fully unblocked to spin up.
    Archival Node Operators will need to wait for the archival datadir, which may take an additional 5-10 hours.

    The datadir can be downloaded from the link found in the OP Mainnet docs: https://community.optimism.io/docs/useful-tools/networks/#links

  • Update
    June 06, 2023 at 5:44 PM
    In progress
    June 06, 2023 at 5:44 PM

    Node Operators: Docker images are now available in our community hub docs.
    op-node version: https://github.com/ethereum-optimism/optimism/releases/tag/op-node%2Fv1.1.0 (Docker Images are in the release notes)

    op-geth version: https://github.com/ethereum-optimism/op-geth/releases/tag/v1.101105.2 (Docker Images are in the release notes)
    Please await the upload of the Migrated Datadir before you can fully spin up your OP Mainnet Bedrock nodes.

  • Update
    June 06, 2023 at 4:36 PM
    In progress
    June 06, 2023 at 4:36 PM

    We are now starting to execute the L2 portion of the migration. This is the longest step in the migration process, and could take up to 1.5 hours. During this phase of the migration, ETH balances and withdrawals will be migrated. Successful completion of this stage will conclude the L2 portion of the migration, and we will perform all related checks before moving on to subsequent phases.

  • In progress
    June 06, 2023 at 4:00 PM
    In progress
    June 06, 2023 at 4:00 PM

    The migration has started. Legacy network deposits and withdrawals have been paused.

    Transaction acceptance on the legacy sequencer has been halted.

  • Planned
    June 06, 2023 at 4:00 PM
    Planned
    June 06, 2023 at 4:00 PM

    The OP Mainnet Bedrock Upgrade is expected to run for 2-4 hours. Find all of the details here:
    https://optimism.io/bedrock-upgrade
    Watch for updates on this status page for:

    • Images for node operators
    • Datadirs for both full node and archival node operators
    • Notifications on when deposits, withdrawals, and the sequencer are back live.