All systems operational

Resolved
Goerli Head Stalled for some node operators

Started
October 05, 2023 at 7:16 AM
Status
Resolved after about 4 hours

Impact

Partial outage
Affected
Goerli
Public API
Bridge UI
Withdrawals
Transaction Sequencing
  • Resolved
    Resolved

    Our team has resolved the Goerli head stall for some node operators, and public infrastructure should now be fully operational for all users.

    As a precaution, we advise all OP Stack node operators (including mainnet chains) to change their op-node to use ws instead of http for the l2 connection to op-geth while we're investigating the underlying issue further. So if you use --l2 http://localhost:8551 to connect to op-geth, change that to --l2 ws://localhost:8551. No need to restart op-geth. We don't expect the issue that affected some Goerli nodes to be a risk to any mainnet OP Stack nodes, but still advise node operators to change this setting as a precaution.

    If you continue to experience an issue, please let us know on Discord.

    Thanks for your patience with us!

  • Identified
    Identified

    Our team has identified the cause of the Goerli head stall for some node operators, and is actively working on a fix.

    At this time, some users of public infrastructure and node operators will continue to experience a head stall.

    We advise node operators to change their op-node to use ws instead of http for the l2 connection to op-geth as a quick remedy while we're working on a proper fix. So if you use --l2 http://localhost:8551 to connect to op-geth, change that to --l2 ws://localhost:8551. No need to restart op-geth.

    We’ll continue to share updates as we have them.

  • Investigating
    Investigating

    Our team is investigating stalled heads on Optimism Goerli. At this time, users and infrastructure provider may experience their safe and unsafe heads of their Goerli nodes stuck.

    We apologize for the inconvenience and will share an update once we have more information.