Completed
Scheduled Kovan/Mainnet Maintenance

Status
Resolved after 26 minutes
Started
February 22, 2022 at 7:00 PM
Completed
February 22, 2022 at 7:26 PM
Affects
Transaction Sequencing
  • Completed
    February 22, 2022 at 7:25 PM

    Maintenance has completed successfully.

  • In progress
    February 22, 2022 at 7:11 PM

    Maintenance is now in progress.

  • Planned
    February 22, 2022 at 7:00 PM

    We are upgrading software on Kovan/Mainnet. We expect minimal downtime.