Completed
Scheduled Kovan and Mainnet Maintenance

Starts
January 25, 2022 at 7:00 PM
Status
Resolved after about 1 hour
Affects
Mainnet
Transaction Sequencing
Kovan
Transaction Sequencing
  • Completed
    January 25, 2022 at 7:45 PM

    The upgrade is complete.

  • In progress
    January 25, 2022 at 7:00 PM

    We are upgrading some of our services.